Standard Development APIs

Availability

This feature is available since openGauss 1.0.0.

Introduction

Standard ODBC 3.5 and JDBC 4.0 APIs are supported.

Benefits

Standard ODBC and JDBC APIs are provided to ensure quick migration of user services to openGauss.

Description

Currently, the standard ODBC 3.5 and JDBC 4.0 APIs are supported. The ODBC API supports SUSE Linux, Windows 32-bit, and Windows 64-bit platforms. The JDBC API supports all platforms.

Enhancements

The function of connecting JDBC to a third-party log framework is added. JDBC can interconnect with a third-party log framework to meet users' log management and control requirements.

Constraints

None.

Dependencies

None.

NOTE: In the Lite scenario, openGauss does not provide ODBC APIs.

Feedback
编组 3备份
    openGauss 2024-04-25 00:46:51
    cancel